Animate this crate.

**Part 1 – adding PWK – Use**

In this tutorial we will add some „life“ to our static placeable and make it more useable. First thing – let's decide, where our player will be standing, while opening the crate, to see its mysterious/dreadful content. Well, it is possible to skip this part and let the game to decide if your placeable is small, but when it is big, this often it results in our poor player running in circles around the placeable or trying to get to it's center (computed by game engine). To avoid this, we will add another dummy and link it to PWK Rootdummy. *If you've read my previous tutorial, you know that dummy in Blender is an Empty, which does not show in a game but is vital to game to make use of your placeable, light, etc.*

Important – it doesn't really matter, how you named the static placeable, but it does – with animated/useable ones, because game uses these parts of name for placeable interaction and use dummies. It's better to follow Bioware naming conventions, i.e prefix and suffix, like crate_001.mdl So, our “use object” dummy in this example will be named 001_pwk_use01.

O.K. Let's do this. Open your blender file with the crate model (or you can use the one I uploaded here, in tutorial files): [https://neverwintervault.org/project/nwn1/other/do-it-blender](https://neverwintervault.org/project/nwn1/other/do-it-blender)

Rename MDL Rootdummy to crate_001, and PWK Rootdummy to crate_001_pwk.
In “Object Mode” add another Empty (Add=>Empty=>Plain Axes), and name it 001_pwk_use01. Move it, so it is placed near the edge of the crate, like shown below:

Make sure that PWK Rootdummy is selected. Click and rename.
Select **crate_001_pwk** as its parent. In Aurora Dummy Properties, Subtype, select: PWK-Use 1

Now, when player uses or opens the placeable, it's done right where you want it.

---

**Note:** Actually, you can add 5 more “so called” interaction dummies, children to your mdl rootdummy, so you can have:

<table>
<thead>
<tr>
<th>Naming</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;suffix&gt;_ground</code></td>
<td>no idea :D</td>
</tr>
<tr>
<td><code>&lt;suffix&gt;_hand</code></td>
<td>where the object is operated on (picklock for example)</td>
</tr>
<tr>
<td><code>&lt;suffix&gt;_head</code></td>
<td>where 'head' FX are played</td>
</tr>
<tr>
<td><code>&lt;suffix&gt;_head_hit</code></td>
<td>no idea :D</td>
</tr>
<tr>
<td><code>&lt;suffix&gt;_impact</code></td>
<td>where impact VFX like magic missile are directed to</td>
</tr>
</tbody>
</table>

From placeable tutorial, Wiki CCG (no longer available)

---

**Part 2 - refining the crate**

The crate model created in previous tutorial was one solid box, without parts that can be opened, and with no “inside”. This time our crate needs some parts which will move to open it, and “inside” part, which player can see, when it is opened.

To create these parts, we will modify our model by adding new faces.

Switch to “Edit Mode” (press Tab or select from drop-down menu). If you didn't “cut” in two your model before, it's time to do it now.

Press Ctrl+r, and move mouse until a magenta line appears, like shown below:
Left – click or press Enter, next press Esc.

Time to make “opening and closing parts. First, we will separate “lid” and split it into 2 mobile elements. Switch to “Face Selection”. Select all the upper faces (right click while holding Shift). When you have them selected, press “p”. From “Separate” menu choose “Selection”.

Now “lid” is converted into another object. We will edit it later. For now, we will hide it from view, to make creating “inside” of crate easier. Switch to “Object Mode”, right-click “lid” and press “h”.
With “lid” conveniently hidden, select rest of the crate and add “Solidify” modifier.

Adjust thickness of the sides of your crate, then apply changes:
Next, we will add some “helper“ dummies as “parents“ to our moveable parts of the crate and divide the “lid“ into 2 parts ("children“ to these dummies). Last, we will create animations.

Switch to “Edit Mode”. Click “Edge Selection” icon. Select two edges at shorter side of crate, press “Tab”. Type “cursor“ and in the menu choose “Snap Cursor to Selected”. This will put 3D cursor where we need to add first “movement“ Empty (Every new object is added to the scene exactly where you've placed 3D cursor).

Switch to “Object Mode” and add Empty (Add=>Empty=>Plain Axes), and name it “move lid_1”. Select “crate_001” as its parent.
Repeat steps: Switch to “Edit Mode”. Click “Edge Selection” icon. Select two edges at opposite shorter side of crate, press “Tab”. Type “cursor” and in the menu choose “Snap Cursor to Selected”. This will put 3D cursor where we need to add first “movement” Empty (Every new object is addex to the scene exactly where you’ve placed 3D cursor).

Switch to “Object Mode” and add Empty (Add=>Empty=>Plain Axes), and this name it “move lid_2”. Select “crate_001” as its parent.

When you have these 2 helpers prepared (move lid_1, move lid_2), press “Alt”+h or select “Show Hidden” from “Object” menu (bottom part of Blender window). This will unhide the “lid”.
Now, to make work on “lid” easier, select it and press “Shift”+”h” - or choose “Hide Unselected” from “Object” menu. This will hide everything else from view.

Next step – we will create two parts (divide “lid” into 2 parts). Each of them will be moved, when Player opens the crate.

O.K. Switch to “Edit Mode”, click “Face Selection” icon, and select half of them. Press “p” and choose Selection, to make it separate object.

Rename object closer to your helper “move_lid_1“ to lid_1, and the second half – to “lid_2”.

When we two lid parts, we need to change their parents.

Because changing “parent” will change the lid location, we will write it down, to restore it later.
Select “lid_1” and change its parent from “crate_001” to “move lid_1”.

See what happens:

When you'll type previous coordinate's values, “lid_1” will return to its earlier position.

Now, repeat these steps for “lid_2” (write down its coordinates, change its parent to “move_lid_2”, type previous values of coordinates).

We can start animate now, but the lids don’t look solid. They are paper – thin. We will add new faces, to make them look more realistic. Let's start with lid_1. First, hide all unnecessary parts: switch to “Object Mode”, select the part you want to edit and press “Shift”+”h”. Switch back to “Edit Mode”. Click “Edge selection” and select all edges shown below:
With edges selected, press “f”. This will create new face.

With the newest face selected, press “u”, then select “Unwrap” (or, if you want to do it another way, you can click Mesh=>UV Unwrap=>Unwrap).

Now the face is textured, but still not good. It shows other parts from the crate too, also, the scale is bad:

For this texture, there's easy fix. We will rescale the face and move it to gray area in UV editor. Move your mouse to the “texture” part of your Blender screen. Don't click yet. First press “s” to
scale it, then “r” to rotate, next type 90. With the face resized and rotated, press “g” to grab the face and drag&drop it to gray area of texture. You should have something like this:

Switch to “Object Mode”, press “Alt” + “h” to show all the parts. Select second lid, and hide the rest, like before. Switch to “Edit Mode” and repeat the steps (select edges, make face, unwrap it, rescale and rotate in UV editor, move it to gray area of your texture).

One last step – we need to add main animation dummy and change some parents. In “Object Mode” make sure, that 3d cursor is exactly in the center (like before, press “Space”, type “cursor“, select “Snap Cursor to Center”. Add Empty and name it “main_anim”. Select “crate_001” as its parent. Change parent of the crate main part (in my example, still named “Plane”), to “main_anim”. Select “move_lid_1” and change its parent from “crate_001” to “main_anim”. Select “move_lid_2” and change its parent from “crate_001” to “main_anim”.

You hierarchy should look like this:
As you can see, PWK still stays the same, no changes here.

*Note:* Avoid spaces in names of your objects in Blender, NWN is very “touchy” when it comes to naming conventions. Some things may not work correctly in game, when their names are too long or with spaces. If you have such names in your models, it’s the last moment to change them. All is set for animation.

**Part 3 – creating animations**

There are 7 kinds of placeable animations in NWN1:

<table>
<thead>
<tr>
<th>Animation Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Damage</td>
<td>Plays when the object is struck and damaged. For most objects it is a simple shiver.</td>
</tr>
<tr>
<td>Default</td>
<td>The animation that occurs all the time unless turned off in the toolset or through a script command. Normally there is nothing in the default animation (reduces load on the CPU)</td>
</tr>
<tr>
<td>Dead</td>
<td>Plays when the object is destroyed. Usually it is dropped below ground level to get it out of sight while, at the same time, an emitter throws chunks of stuff into the area and creates explosions.</td>
</tr>
<tr>
<td>On/Open</td>
<td>Animation that plays when the object is ‘on’/’open’</td>
</tr>
<tr>
<td>Off/Closed</td>
<td>Animation that plays when the object is ‘off’/’closed’</td>
</tr>
<tr>
<td>On2Off/Open2Close</td>
<td>Animation that plays when the object switches form on to off. For example, levers go through this state when switching from on to off. For chests or other containers - plays when object switches from open to close.</td>
</tr>
<tr>
<td>Off2On/Close2Open</td>
<td>Reverse of On2Off/Close2Open</td>
</tr>
</tbody>
</table>

Animations are created from so-called “key-frames”. It’s similar to movie – one key-frame is like one film frame. One second of played animation consists, by default, of 25 key-frames. So, if you want to create an animation 2 seconds long, you will need 50 key-frames (2*25) for it. For most of the placeables, four of them will be “static” (there's no visible movement): Default, Dead, On/Open, Off/Closed. These don't need more than 1 keyframe each (because nothing happens, the game engine can just replay this same keyframe over and over again).

Our crate is definitely container, so we will choose versions with “open” and “close” rather then “on/off”.

I'll describe process of creating animations with settings, that worked well for me. You might want to experiment with movement range, timing, etc.

First to create will be “default” animation – basically, it is the way, the crate is seen in game, when nothing is done with it.

Look at the right side of Blender window. Follow the instruction seen on picture below.
This will create a new scene, where we'll set parameters of the first animation.

Expand this scene, then expand “crate_001.default”. As you can see, new objects are copies of your original “crate objects” with “.default” extension added. Because we won't change location or rotation of the crate or any of its parts, 2 keyframes “recorded” for “main_anim.default” will suffice. Click to select “main_anim.default”.

1. Select mdl rootdummy by clicking it
2. This "Object Properties" must be ON
4. Select "crate_01" as animation root
5. Type "default" and click "＋"
Look at the bottom of Blender window. Here’s timeline for animations. Currently it is set 1 to 250 keyframes. We will need 1 to 2.

Scroll your middle mouse button to resize the line, keep this button pressed and drag to right, to move the timeline. You should end with something like this:

Left-click on the “1” keyframe. Press “i”, choose “Location”. This will add first keyframe to “recorded” animation.
Now, click to select “2” keyframe and again press “i”, choose location. That's all. We can create next animation.

“Close” animation is actually identical to “default” in the crate. Once again, we will need 2 keyframes, but with different numbers.

Return to your original scene and once again select “crate_001”. Change the name of animation to “close” and set “Transitiontime” to 0.25. Click “+” to create new animation scene.
Expand new scene “close” and “crate_001.close”. Select “main_anim.close”. In Timeline type “3” for “Start” keyframe and “4” for “End” keyframe.

As you've probably already guessed, this same steps will be used for creating next scene “open” (return to your original scene, select “crate_001”, type new name, click “+”) - only once Transition time is set to 0.25, we won't need to change that.

In this scene we will need “opened” crate, so we will move the 2 lids, before creating new keyframes.

Expand the “open” scene content. We will use “move_lid_1.open” and “move_lid_2.open” to set crate to “open” (actually, to opened, but this is how animation is named).

Select “move_lid_1.open”, type “g”, next “y”, next “0.75”, confirm by pressing “Enter” or left-clicking. This will move helper (and the lid attached to it) 0.75 unit along “y” axis.

Now click “move_lid_2.open”, type “g”, next “y”, next “-0.75”, confirm by pressing “Enter” or left-clicking. This will move helper (and the lid attached to it) to opposite (to lid_1) direction.

When both lids are in the right places, it's time to add keyframes. Like before, this animation will need only 2 of them. In Timeline type “5” for “Start” keyframe and “6” for “End” keyframe. This time, each of helpers needs keyframes. Select “move_lid_1.open” - select “5” keyframe, press “i”, choose “Location”. Select “6” keyframe, press “i”, choose “Location” again.
Repeat adding keyframes with “move_lid_2.open” selected.

That's all for “open” animation scene.

Next – we will create “dead” animation scene. Create the new scene the way you did before.
For this scene, select “main_anim.dead”. In Timeline type “7” for “Start” keyframe and “8” for “End” keyframe. With “main_anim.dead” selected, type “g”, next “z”, next “-2”, confirm by pressing “Enter” or left-clicking. This will move helper -2 unit along “z” axis. Left-click on the “7” keyframe. Press “i”, choose “Location”. Do this same for “8” keyframe /remember, that “main_anim.dead” must be selected all the time you add “location” to keyframes 7 and 8/. When all the “static” scenes (default, close, open, dead) are created, we can do the scenes, where crate and its lids move. There are scenes “close2open”, “open2close” and “damage”.

Create new animation scene and name it “close2open”.

As you remember, for one second of animation played, you will need 25 keyframes.

We will create “close2open” animation, which lasts approximately 1,5 sec. That gives us count of 40 keyframes. In Timeline type “10” for “Start” keyframe and “50” for “End” keyframe.

Expand the scene list and select “move_lid_1.close2open”. Click on keyframe “10”. Press “i”, choose “Location”. Type “g”, next “y”, next “0.75”, confirm. This will move the helper and the lid into “open” position. With “move_lid_1.close2open” still selected, click on keyframe “50”. Press “i”, choose “Location”.

When it is done, select “move_lid_2.close2open”. Click on keyframe “10”. Press “i”, choose “Location”. Type “g”, next “y”, next “-0.75”, confirm. Press “i”, choose “Location”.

That’s all for “close2open”. Next animation scene is kind of reverse - “open2close” will be displayed, when our crate is closing. And it will be shorter – 1 second (that will need 25 keyframes).

O.K. Create new animation scene, named “open2close”. In Timeline type “52” for “Start” keyframe and “77” for “End” keyframe. Our “starting point” will be opened crate, so, like before,
move lids along “y” axis. This part is repetition of the things you’ve done for “open” scene. (Select “move_lid_1.open2close”. Type “g”, next “y”, next “0.75”, confirm, next “move_lid_2.open2close”. Type “g”, next “y”, next “-0.75”, confirm). Once the crate is opened, add “location” to keyframe “52” for each lid helper.

Select “move_lid_1.open2close”. Type “g”, next “y”, next “-0.75”, confirm, next “move_lid_2.open2close”. Type “g”, next “y”, next “0.75”, confirm. This will return lids to “closed” state. Once the crate is closed, add “location” to keyframe “77” for each lid helper. Done!

Almost finished – only one more animation left.

Create new animation scene called “damage”. “Damage” is played, when placeable is successfully attacked. Here it will be a small movement, back and forth, of the entire crate – so it will be added to “main_anim.damage”. Expand scene object list and select it. For this short movement 15 keyframes should be enough. In Timeline type “79” for “Start” keyframe and “94” for “End” keyframe. Add “location” to keyframe “79”. Move to keyframe somewhere in the middle of the timeline. “86” should be enough. Type “g”, next “x”, next “-0.1”, confirm. This will “push” the crate back along “x” axis. Add “location” to keyframe “86”. Move to the last keyframe (“94”). Type “g”, next “x”, next “0.1”, confirm. This will return the crate to “starting” position. Add “location” to this keyframe.

Time to export our placeable+animations. Select original “crate_001” mdl rootdummy.

Very important – uncheck “Animation” in its properties.
Go to File=>Export=>Aurora(.mdl)

Export the crate.

After successful export you should have 2 files here_goes_name.mdl and here_goes_name.pwk.

You can now add them to your hak or playtest by renaming to “plc_a01.mdl” and plc_a01.pwk” (replaces standard armoire) – and putting it to Override folder.

Addition:

Further refining – changing sounds. Nearly every placeable plays different sounds, when opened, closed, destroyed, used, etc. This crate is supposed to sound “metallic”. The place to change it is in .2das. Extract both placeables.2da and placeableobjsnds.2da. Open them in any text editor, even
Notepad will do the job.

In placeables.2da there's a column “SoundAppType” which contains a number. This number refers to number of sounds set in “placeableobjsnds.2da”. For example, “Armoire 1” has “SoundAppType” nr 13. If you open placeableobjsnds.2da, you'll see in row 13:

<table>
<thead>
<tr>
<th>Label</th>
<th>Armortype</th>
<th>Opened</th>
<th>Closed</th>
<th>Destroyed</th>
<th>Used</th>
<th>Locked</th>
</tr>
</thead>
<tbody>
<tr>
<td>13</td>
<td>crate_large</td>
<td>wood</td>
<td>as_sw_crateop1</td>
<td>as_sw_cratecl1</td>
<td>cb_bu_woodlrg</td>
<td>****</td>
</tr>
</tbody>
</table>

You can use something else in the newly created crate. Look at the line 28:

<table>
<thead>
<tr>
<th>Label</th>
<th>Armortype</th>
<th>Opened</th>
<th>Closed</th>
<th>Destroyed</th>
<th>Used</th>
<th>Locked</th>
</tr>
</thead>
<tbody>
<tr>
<td>28</td>
<td>metal_object_large</td>
<td>plate</td>
<td>as_sw_metalop1</td>
<td>as_sw_metalcl1</td>
<td>cb_bu_metalrg</td>
<td>****</td>
</tr>
</tbody>
</table>

This is much better. Now, when you add the crate to your hak, edit placeables.2da (copy/paste last line, renumber, enter your placeable name, set “SoundAppType” to 28).

This tutorial doesn't cover all. There are many other animations you can have – rotation – like in opened chest, mix of rotation and location, etc. When you press “i” adding keyframe, choose the animation which corresponds with your placeable movement.

Useful links:

More advanced (at least, more advanced than mine) animation in Blender:

https://www.youtube.com/watch?v=bUD1n-qIiM4

https://www.youtube.com/watch?v=q33AyW0eYRk&list=PLCtL34Gw96S_jWfy0CTYV772kHfr15qmM&index=1

And new texturing tutorial: https://neverwintervault.org/article/tutorial/do-it-blender-addition-apply-texture-parts-selected-faces