You are here

NWN1 Community Patch 1.71 (final)

Primary tabs

Game: 
Requirements: 
Official: 
Platform: 
Version From: 
1.69 or 1.70
Version To: 
1.71
Patch: 
AttachmentSize
File nwnpatch171.exe (17308)55.99 MB
Description: 

This patch requires the official english version of patch 1.69 with both expansions installed! Also please note that several game distributions are bugged and doesn't contain all required files to install 1.71. This is namely the problem of the Diamond edition. Running 1.69 Critical rebuild before installing 1.71 is recommended.


ABOUT THE PATCH

The Community patch 1.70-1 is an unofficial patch, that is compiled from work of numerous NWN community members and completed by Shadooow. Patch contains thousand of bugfixes and brings into game several new possibilities, especially for module builders.

This patch does work almost the same way as old official patches in past. The only difference is that, the Community patch doesn't affect the game version and its fully compatible with previous official patch - 1.69. Players without this unofficial patch will still be able to play on servers with the patch and viceversa. Also, players without patch will still be able to see your server in gamespy server list. Installing onto lower game version is probably possible, but wasn't tested and its not recommmended. The same apply for game without expansions.

Also, this patch is fully compatible with any custom content like CEP, PRC, Project Q etc. meaning, that if you install the patch, non of these will break, everything will still work fine. But obviously you won't take advantage of all patch features and fixes until you (or CEP/PRC/Q team) merge 2DAs (and possibly spell scripts). This is standard behaviour of any patch. It was always like this, the problem now is that its been quite a while and nobody expected there will ever be another patch, so merging could be quite problematic. For this reason community patch contains a 3rd party tool called Auto 2DA Merger that will automatically update any 2DAs.


ABOUT PATCH CONTENT

There was a lot of controversy about what is included in this patch. But most, if not all these doubts were caused by misinterpretations of certain fixes which wasn't fully explained. There are a lot of different issues and not everyone is aware of them and some folks who didn't even knew how that things worked or whats was broken on it misinterpreted my fix/change and instead they ask, they simply stated that the Patch is wrong.

Also note that this project doesn't fixes only so called "confirmed" bugs. Certain NWN experts claim that not everything is a bug unless it's definitely clear and confirmed. But since there is noone who could really confirm what is bug and what is not, an opinions on certain issues vary. Therefore this project describe bug as anything that doesn't make a sense. This is why despite the fact that the Bioware clearly stated that they know about UMD issue and that it was intented, Patch 1.70 changed and "fixed" it anyway. It simply didn't make sense.

Due to this fact it could be hard to distinguish between a feature or a fix, but it shouldn't matter. Every single change included in this patch was designed to be balanced for all kinds of environments and game types and mainly: to make sense.

The patch contains also many new and unique features, like a possibility to make a trap with DC of 65 and damage of 500-1000. Of course none of these features are "on" by default. Its simply a possibility for buiders of specific environments and its up to them if they uses it or not.


AUTO 2DA MERGER

This utility is located in 1.70 builder resources and allows to automatically merge all your 2das with the patch's 1.70 changes. To do this you have to only copy all your 2das into folders "yours" and then run the program from one of the batch files. See README.txt in the folder with automerger for more details.


UNINSTALLATION

In case of any issues its possible to revert to 1.69 easily using 1.69 critical rebuild.