You are here

Interior Walkmesh Skating Movement

5 posts / 0 new
Last post
BowShatter
Interior Walkmesh Skating Movement

When creating and baking interior areas in the toolset, the walkmesh tends to be messy. (Yes, I've tried converting placables to environmental objects)

The PC can still walk, but it often results in a buggy walking animation, sometimes even t-pose sliding. It does not however affect NPCs walking/running, their animations are fine. 

If walkmesh is the problem, I'm not sure how to edit interiors' walkmesh. 

  • up
    50%
  • down
    50%
rjshae

I wonder if the culprit is having a bunch of tiny mesh triangles in your baked walk mesh? That may mess up the walk pathing algorithm.

A couple of ways to avoid adding too many walk mesh faces are: (1) put non-environment objects placeables in areas where the walk mesh is already dense, such as along the sides, and (2) following the existing mesh lines when you add a walk mesh cutter.

  • up
    50%
  • down
    50%
BowShatter

I tried adding non-environmental placables on cluttered walkmesh and it does indeed reduce the skating movement! Thanks!

Walkmesh cutter dosen't seem to work in interiors though.

  • up
    50%
  • down
    50%
Tchos

There's something wrong with your setup if the walkmesh cutter isn't working in your interiors.

Tchos' Gaming and Modding (blog)  |  List of mods for numerous games
Owner of: BG1&2 Complete | IWD Complete | IWD2 | PS:T | NWN Diamond | NWN2 Platinum | DA:O | Arcanum | VtM:B | ToEE

  • up
    50%
  • down
    50%
rjshae

Agreed. Either the area wasn't baked afterward, the Baked tab is turned off in the toolbar, or you're using the wrong trigger.

  • up
    50%
  • down
    50%