You are here

Animating Placeables

7 posts / 0 new
Last post
jestemwlodzimierz
jestemwlodzimierz's picture
Animating Placeables

I'm having troubles animating my custom placeble. I need one part to play the animation and the other to stand still. I've put "PLC_X" into the NWN2_ModelName in Placeables.2da and then "PLC_X_01" in AttachedModelName. It doesn't work the way I want. Both PLC_X and PLC_X_01 are playing the animation. Where lies the secret of my failure?

Please help.

  • up
    50%
  • down
    50%
4760
4760's picture

Did you also export PLC_X and PLC_X_01 as two separate mdb's? And in placeables.2da, did you set PlaceableModelType value to 2?

  • up
    50%
  • down
    50%
jestemwlodzimierz
jestemwlodzimierz's picture

Yup - did all of those

  • up
    50%
  • down
    50%
4760
4760's picture

Well, in that case the only other options I can think of are that PLC_X_01 is not linked to PLC_X (since you're making animated placeables, and the gr2/fbx converter is not released yet, you're using 3ds max: the "link" button is the third from the left, looking like a chain between two squares) or the animation in the gr2 files has no still part (which could be the case if there's another PLC_X in your override, taking precedence over your newly created one).

To put it in a nutshell, for a placeable PLC_X with an animated part, you need to:

  • name the animated part as the main part, followed by "_01"
  • link the animated part to the main part (so you have two different objects)
  • export PLC_X as a single mdb
  • export PLC_X_01 as a single mdb
  • select PLC_X and PLC_X_01 and export PLC_X_skel.gr2 (in the Expotron settings, make sure the "move to origin" box is unchecked, and it's exported as a "model"
  • select the timeframe between the first frame and the last one of the animation (in case you have several animations, like "open", "close", etc.), then select PLC_X and PLC_X_01 and export PLC_X_Idle, PLC_X_PLC_Open, PLC_X_PLC_Close, PLC_X_PLC_OpenIdle, PLC_X_PLC_TurnOn (usually). I did not forget the "_PLC_" part for the Idle animation by the way.
  • in placeables.2da, make sure that PlaceableModelType is set to 2, NWN2_Skeleton and NWN2_ModelName refer to PLC_X, AttachedModelName to PLC_X_01

Hope this helps

  • up
    50%
  • down
    50%
jestemwlodzimierz
jestemwlodzimierz's picture

I'm using blender for models, though... :-/

  • up
    50%
  • down
    50%
jestemwlodzimierz
jestemwlodzimierz's picture

Ok, I got it work perfectly - no need to link anything. Just make sure the moving bone is named "PLC_X_01" and you're good. Thanks a lot!

  • up
    50%
  • down
    50%
Trinital
Trinital's picture

Would love a Step by Step guide on this haha..

  • up
    50%
  • down
    50%