You are here

Error on import with NWMax and Gmax

4 posts / 0 new
Last post
JFK
Error on import with NWMax and Gmax

Hi all,

I did a fresh install on gMax and NWMax, but trying to load a model fails with the error:

Maxscript Rollout Handler Exception:

Unknown property "animations" in undefined

 

If I re-run the startup script, the model has loaded, but without animations. 

Anyone have an idea why my gMax/NWMax isn't working?

 

Windows 10

 

Thanks,

 

JFK

My other  sword is a +5 Holy Avenger!

  • up
    50%
  • down
    50%
krighaur

Do you have the granny2.dll in your gmax directory? If no you can find it in your NWN game directory, then copy/paste it in gmax


  • up
    50%
  • down
    50%
Zwerkules

The granny2.dll is for NWN2 models. NWmax doesn't need it.

JFK, does this happen for all models or a specific one? The error looks like the file is corrupted and an endnode or endmodelgeom is missing before the start of the animations. If it happens for all models it has to have a different reason.

 

  • up
    50%
  • down
    50%
JFK

Hmm.... well I guess you're right, Zwerkules. It appears to be the model I was loading. I thought I'd loaded a couple different ones to test this out, but apparently not.

Seems to be working with other models. It was strange, because after the error, if I re-ran the script to start NWMax, the model would appear, but with no animations. Then, I could successfully load "animations only" with NWMax, and the model would then have its animations.

Thanks for keeping me honest and making me double check that I was trying more than the same model over and over. ;)

-JFK

  • up
    100%
  • down
    0%